Exception when trying to update.

Mar 5, 2015 at 10:27 AM
I have kinda the same issue as stated here: https://autoupdaterdotnet.codeplex.com/discussions/532853


When i hit update i get hit by a System.ComponentModel.Win32Exception (0x80004005) The specified executable is not a valid application for this OS platform.

Though compared to the other discussion, the file i try to download is a simple WPF app with 2 labels and a button, just to test if i could get the updater working before implementing it.

Though sometimes it works and sometimes it doesn't, it's really really wierd..

I'm suspecting something happens in the AutoUpdater.NET that makes my website time out.. because after i get the error i just get "No data recieved" Errorcode: ERR_EMPTY_RESPONSE (chrome) When trying to browse the location in the browser.

Files:
xmlpath: http://publishingtests.frostshock.dk/UpdaterTest/test.xml
htmlpath: http://publishingtests.frostshock.dk/UpdaterTest/changelog.html
program: http://publishingtests.frostshock.dk/UpdaterTest/program2/WpfApplication3.exe
I know the html path is not relevant, but i thought i would link it anyways so it's there :)


It's possible to try it by downloading the first version here: http://publishingtests.frostshock.dk/UpdaterTest/program/WpfApplication3.exe
then trying to update and if it fails, go to http://publishingtests.frostshock.dk/UpdaterTest/program2/WpfApplication3.exe and notice you get an error.
Coordinator
Mar 6, 2015 at 5:13 AM
Can you try the application from following link? For the issue you mentioned about website timeout in chrome, AutoUpdater.NET can't cause that type of issue. It must be a server side problem. I see that your website is hosted by unoeuro.com. Please contact them and ask them why this is happening.

https://www.dropbox.com/s/4v4vvzth113wtdh/WPFTestApp.zip?dl=0